Skip to content
Advertisements

User ASADMIN does not have the privilege of deploying/undeploying composites

I am trying to deploy the SOAP service in ebs 12.2.6 with integrated SOA gateway. I can able to deploy the wsdl file but I can’t able to view wsdl files. The below error appeared when I try to open view wsdl file

“Failed to Load a composite for composite identified by default”

So I realized  the error seems to be part of SOA server. I looked the SOA server log from EM console. It shows below error

#
#SEARCH_CRITERIA
# START_TIME: 2016-11-17T11:16:46.968+03:00
# END_TIME: 2016-11-17T12:16:46.968+03:00
# MESSAGE_TYPES:INCIDENT_ERROR, ERROR, UNKNOWN

#SELECTED_TARGETS_LIST
# /Farm_base_domain/base_domain/soa_server1/soa-infra:oracle_soainfra
#

[2016-11-17T12:00:57.533+03:00] [soa_server1] [ERROR] [SOA-21537] [oracle.integration.platform.blocks.deploy.servlet] [host: dbs-10-1-4-201.tst.RUH.ace-ins.com] [nwaddr: 10.1.4.201] [tid: [ACTIVE].ExecuteThread: ‘2’ for queue: ‘weblogic.kernel.Default (self-tuning)’] [userId: ASADMIN] [ecid: 005GNi0iuAiESO15zvg8yW00004y00001p,1:26140:36] [APP: soa-infra] [DSID: 0000LXlX7_9EOP15zvg8yW1OBMle000006] Sending back error message: User ASADMIN does not have the privilege of deploying/undeploying composites. Only users of SOAAdmin/SOAOperator role are authorized to deploy/undeploy composites..
[2016-11-17T12:01:17.366+03:00] [soa_server1] [ERROR] [SOA-21537] [oracle.integration.platform.blocks.deploy.servlet] [host: dbs-10-1-4-201.tst.RUH.ace-ins.com] [nwaddr: 10.1.4.201] [tid: [ACTIVE].ExecuteThread: ‘0’ for queue: ‘weblogic.kernel.Default (self-tuning)’] [userId: ASADMIN] [ecid: 005GNi1pk8XESO15zvg8yW00004y00001q,1:26142:37] [APP: soa-infra] [DSID: 0000LXlXCYjEOP15zvg8yW1OBMle000007] Sending back error message: User ASADMIN does not have the privilege of deploying/undeploying composites. Only users of SOAAdmin/SOAOperator role are authorized to deploy/undeploy composites..

#
#MESSAGE_COUNT: 2
#

So The ASADMIN requires some privileges in SOA server for deploying services.

Solution :

SOA Server Enterprise Manager Console

–> Weblogic Domain –> <domain name>

–> Security –> Application roles

–> Application Stripe — soa-infra

Select SOAAdmin roleand click edit, and add user ASADMIN

Select SOAOperator role and click edit, and add user ASADMIN

 

Again now  I tried to deploy the services, it’s working fine.

Advertisements
No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: